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Creating Animation for LightWave
3D in Life Forms Studio 3

Introducing a new way to animate characters
for LightWave 3D.

Character Animation is one of the most
rewarding albeit challenging type of animation
you can undertake as a 3D artist. Now, there is
a new way for LightWave users to animate.
You'll want to read this document if you are
looking for ways to:

e Create more motion intensive projects.

e Apply mocap data to models in LightWave
scene files.

This tutorial describes how we set up the
project “Vampire-alive!”. Vampire Alive was
created with a model created in LightWave. Us-
ing bones, we applied mocap sequences to a
mesh and rendered it in LightWave.

You will need Life Forms Studio 3.0 and
LightWave 5.6, and of course the new Light-
Wave plug-ins from Credo Interactive Inc.



How does it work?

Life Forms imports and exports the LightWave’s scene file (.lws).
This gives you maximum freedom in your 3D projects. You will be
able to:

* Insert motion into existing scene files using the Merge option.

* Use Models and Motions in Life Forms PowerMoves Library for
LightWave projects.

¢ Use LightWave’s ability to deform meshes by animating bones
in Life Forms.

The diagram below shows how you can move data between Life
Forms and LightWave. As you can see, there are many ways to effi-
ciently create a motion-rich scene file. You can begin your project in
LightWave by building custom models. Or, you can start in Life
Forms by using the models in the Model Gallery and PowerMoves
Libraries. You can choose between using bones or segmented mod-

els.
LightWave “N
LW LWS
q S trv & B *) (Motion with
(Geometry ones Geometry &/or .st
. . MERGE
Life Forms Studio 3 (Exports motion data to
an existing scene file)
Important Please read the Installation instructions and

Release Notes that come with the LightWave 3D plug-ins. These
documents contain important information that is specific to the
released version of the LightWave 3D plug-in.



TIntorial:

Animating Jointed Models

Objective

Summary

There is no one prescribed way of using Life Forms to enhance your
scene files.

This tutorial shows you how to animate jointed models for Light-
Wave 3D. The illustration below summarizes how data moves
between LightWave and Life Forms in this tutorial. For other ways of
using Life Forms see Other Techniques.

LightWave

Iws file with model

(containing LWS l
jointed models)

Life Forms Studio

Life Forms will animate any jointed model that has been correctly
set up in LightWave. Once in Life Forms you can animate models
very efficiently by using Life Form’s procedural Walk Generator, key-
framing and by pasting motion capture data. Here, we’'ll show you
how to apply motion captured skate sequences to a jointed or seg-
mented model. We'll also tweak the mocap data to get the desired
results.

Life Forms will open any polygonal segmented model from Light-
Wave allowing you to animate it quickly and easily.

Important. Please note the following:

1 If you have Life Forms Classic 3.0 or Life Forms 2.1 you will
need to upgrade to the Studio version to use Life Forms with
LightWave.

2 You will need latest Lightwave plug-in. Please contact us at
info@credo-interactive.com.



Conventions and Files used

Life Forms

This tutorial uses both LightWave 3D 5.6 or Inspire 3D, AND Life
Forms Studio 3. To make it clear which application to use at each
step, the application is given on the left. Sample files are given at
the end of the each step.

Setting Up the Segmented Model

In LightWave, you will need build or import a segmented model.
Before it can be animated, you must set its pivot points and link
each joint to another creating a hierarchy of joints. Remember
that all LWO files for this model must be contained in the same
folder.

Remove all but one Null root object

Unlike LightWave, Life Forms requires that each model has only
one root object. The root’s position and rotation is inherited by all
the model’s joint.

Save the file as a LightWave scene file (LWS)

Before saving the model in a scene file you should turn off all IK
settings and remove all frames of animation as these are not
read correctly by Life Forms. Save the file.

Open the LWS file in Life Forms

In the File menu > Open. In the Open dialog box, locate the LWS
file and click OK. When the file is open, you are ready to animate
the model.

Apply Motion Capture data

Open a motion captured motion, for example Exercise.Ifa in Life
Forms 3.0 Demo folder / Tutorial folder.

Copy all frames of its animation. Click in the left hand grey panel
in the Timeline window to select all frames and choose Edit
menu > Copy.

Click on the first frame of the destination file. This positions the
insertion point at the first frame. In the Edit menu > Paste
Default submenu, be sure that paste Relative Location and
Absolute Facing is checked. Choose Edit menu > Paste.

The Joint Map Editor appears to allow you to match the source
and destination joints. This tells Life Forms where to paste the
motion data. More information about the Joint Map editor is
found in the Life Forms User Guide.



Life Forms

LightWave

Repeat the copy and paste procedure to apply the motion data
from HipHop.Ifa (also found in the Tutorial folder) after the first
sequence.

Tweaking the Motion Capture data

After mocap is applied to a model, you might notice that mocap
may look awkward when applied to a model whose rest position
is not exactly as that of the mocap skeleton. For example, if the
legs are of the segmented model are slightly a part walk or run
animations will be slightly off when applied to that model. You
can correct these kinds of problems by using the Range edit
function to apply a relative rotation to the affected joints. More
information about using the Range edit function is found in the
Life Forms 3 Demo folder/ Tutorial folder.

You can also add keyframes to smooth out the transition
between the two motion capture sequences as we have done.
Choose Edit > Insert to insert one keyframe. To insert more, click
on the frame before which you want to add empty frames.
Position the mouse over the Insertion point’s handle. When the
cursor changes to a double-headed arrow click and drag to
insert as many keyframes as you want.

Merge motion to the original LWS file

In Life Forms, choose File menu > Export. In the Export file type,
click the LightWave icon.

Deselect Bones only.
Select the Merge.

Click the Choose button. This opens the dialog box that lets you
locate the source LWS file. Locate and select the file then click
Open. In the Export dialog box, click OK to merge the motion
data to the source LWS file.

“Merging” data to a LWS file allows you to add just the motion
data to the LWS file. All the color, texture and lighting setup in
the source LWS file is preserved. If you added other models in
Life Forms you cannot choose to Merge. You must choose to
export with Geometry.

Using Segmented Models that come with Life Forms

Life Forms reads and writes geometry in the LWS file format, you
can bring segmented models into Life Forms for animation. You can
also start you project in Life Forms using models from the Model
gallery and PowerMoves Library. When you export LWS files click
Geometry. This will export the motion and geometry for these mod-



els. The following illustration shows how two ways of working with
segmented models.

Model Gallery

PowerMoves Library

PuppetMaster**

S

LightWave

+ Models

Life Forms Studio

Merge motion

:;le’csh to original

! LWS file. .

Segmented ¢ LWS (with

models)* Geometry)
Life Forms Studio LightWave

* It is recommended that you delete any keyframes before import-
ing the LWS file to Life Forms.

** QOptional: PuppetMaster is a LightWave 3D plug-in. It allows you
to create segmented models by cutting up mesh models. When you
render the animation, it will perform skinning to hide unwanted
seams.



TIntorial:

Animating a Mesh using Bones

Objective

Boning a mesh

Summary

This tutorial shows you how to animate bones for LightWave. The
motion of the bones will deform and animate a mesh Vampire in
LightWave. The illustration below summarizes how data moves
between LightWave and Life Forms in this tutorial.

Life Forms Studio

BVH Mocap data

(containing
Motion data

with Bones LWS *
only)

LightWave

Critical to this tutorial, is knowing how to bone a mesh. Setting up
bones properly to animate a mesh requires you to have a solid
understanding of how Lightwave handles bones (and some patience
too). The LightWave User Guide has excellent documentation on
how to set bone strength, rest length, and on how to use joint com-
pensation to control the way bones affect the mesh.

In this tutorial, show you how to bring BVH motion data as bones
into LightWave and apply it to a mesh model.

Important. Please note the following:

3 If you have Life Forms Classic 3.0 or Life Forms 2.1 you will
need to upgrade to the Studio version to use Life Forms with
LightWave 3D and Inspire 3D.

4 You will need latest Lightwave plug-in. You can download it from
the page dedicated to LightWave 3D and Inspire 3D users at
http://www.credo-interactive.com.



Conventions and Files used

LightWave

LightWave

This tutorial uses both LightWave 5.6 and Life Forms Studio 3. To
make it clear which application to use at each step, the application
is given on the left.

Export skeleton in the default position

In Life Forms, select a motion capture file. Clear all keyframes
from the animation. Set the bones to have the same default
position as the mesh — this is usually legs slightly apart and
arms stretch out to the side at shoulder height. Then, export a
single keyframe of the skeleton in its default position in a LWS
file.

Replace the Null root object

In LightWave, open the LWS file.

Then, replace the null root object of the skeleton with the Mesh
object. You can do this in the Object dialog box by clicking the
Replace Object button.

Don’t worry if the Mesh is terribly distorted. This problem will be
fixed when you set the rest position of the Arm bones.

Resize the Mesh to fit the bones

Open the Modeler, and get the Mesh. You will now have to size
and position the mesh in the modeler. Check each change using
the Put button and switch to Layout mode. Make all bones Active
to see how the bones interact with the mesh.

Keep resizing and positioning the mesh in the Modeler, and
checking the effect in layout mode until you see that the mesh
and bones fit together well.

Now you want to save the adjusted Mesh as a new LWO file.
Name it so that you know which skeleton to use it with.

Note You may have to zero the rest position of the root bone, or
conversely offset the mesh from it's zero position.

Adjust the Bone rest position

This is done by rotating the bones until they fit properly within
the mesh. Note down the H, P and B values of the rotation. Open
the Object dialog box, and click Object Skeleton. Select the joint
then click Rest Position. Enter the H, P, B values and click OK.

Note that the bones no longer distort the mesh.



Export Motion data from Life Forms

Open the motion capture file from which you exported the
bones. Export this file, with all its keyframes, as a LWS file. In the
Export dialog box, Click Bones only. Click OK to export.

Set the correct Rest position

In LightWave, open the Object panel. Click Object Skeleton,
select the joint and click Rest Position. Enter the H, P, B values
you recorded in step 4.

Apply adjusted Mesh to the motion

In LightWave, open the LWS scene file with the animated
skeleton. Replace the null object with the adjusted mesh, and
voila - you have an animated mesh.

Adjust the Bones strength

Refine the interaction between the bones and mesh by adjusting
bones strength and rest lengths. Pinching can be controlled
using Joint compensation.

LightWave

What Life Form's reads:

As Life Forms opens a LightWave scene file it interprets only the
information needed to let you animate models in Life Forms. It
reads the following data from scene files:

Geometry — both Single -mesh & Segmented (.Iwo files)
Bones — any bones you have set up in LightWave

This will mean that you can animate any articulated model in Life
Forms that you can create in LightWave, or that you already have in
an existing project.

Coming Soon! We are currently writing a tutorial that will show you
how to import the bones that you have set up in LightWave into Life
Forms for animation, and then how to export the animation back
into LightWave to animate a mesh model.

Life Forms will also read any keyframed rotational motion.*



What Life Form’s writes:

Life Forms can export animation you created - either by using
mocap data, procedurally using the Walk Generator or by keyfram-
ing to LightWave. You have several options:

Merge the motion data to a scene file — If you have a scene file
that contains objects that were animated in Life Forms, you can
merge the animation of those objects to this scene file. This option
exports motion without the geometry and preserves other scene
elements such as camera, and lights. Texture and colors applied
to objects are also preserved.

Export Motion with Bones Only — Exports a new scene file. Allows
you to export bones with animation. The benefit of this is that you
can attach the bones to a mesh in LightWave.

Export Motion with Geometry — Exports a scene file, creating new
object files (.lwo) in the content directory for all models in Life
Forms. Note, any bones in the Life Forms will also be exported as
objects.

What Life Forms doesn’t read or write

Project Constraints

What it doesn’t read are cameras, lights, textures and colors. When

it

reads in the model it will ignore any inverse kinematics (IK) set-

tings you’ve set up because Life Forms has its own IK system. Bear-
ing these factors in mind you should:

User the Merge command to add motion data. The Merge com-
mand inserts just the motion data to the.lws. The other scene ele-
ments are unaffected.

Organize the project so that you color and apply textures to mod-
els, set up cameras, lights and other scene elements after creat-
ing motion in Life Forms

For existing projects, remember to turn of all IK settings and goal
objects before saving the file for Life Forms.

A WO N B

Models must be polygonal meshes
Models must have only one null object
Only the root of a hierarchy may contain translations

Importing Scene files with Motion data into Life Forms is NOT
recommended.



5 Merging animation to Scene files that contain motion data is
NOT recommended.

6 Life Forms does not read Lightwave’s IK settings from the Scene
file. It is recommended that you disable IK set up and remove
goal objects before saving a Scene file for Life Forms.

General Concepts

Setting up Segmented Models for animation

For Life Forms can only animated segmented or articulated model
properly when the model’s pivot points are correct, and its joints are
linked in a hierarchy. In LightWave’'s Modeler, objects can be
parented to others to set up a hierarchy. You can also set the pivot
point for each object. You should rotate the joints in Layout mode to
check that the pivot points are appropriate for the model.

Why Hierarchy is Important

The axis of each joint is relative to the position of the joint. Another
way of expressing this concept is that each joint has its own local
axis. The axes of a joint changes with the position of its parent joint
(e.g. the upper arm is the parent of the lower arm).

Some motion data file formats store relative instead of absolute
rotation angles, for example BioVision BVH format. Relative rotation
angles are the angles of rotation given relative to the parent joint's
local axes. When motion data is recorded in this way, the model that
the data will be applied to must have the same hierarchy as the
data in the motion file.

Why Pivot Points are Important

To understand how pivot points affect the motion applied to the
model, you have to understand how motion data is described. The
position of a joint is described as the angle of rotation around the
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joint’s pivot point. When motion data is applied it rotates the joint
around the pivot point defined in the Modeler. Thus, when the pivot
points of the model are wrong, the motion data will rotate the joint
incorrectly. It may cause the joints to over or under rotate, or cause
joints to break off from adjacent joints.

This document is still being worked on. This document will be
updated as more complete information is available. You contribu-

tions and feedback are welcomed. Please send them to info@credo-
interactive.com.
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